Joomla TemplatesBest Web HostingBest Joomla Hosting
Zaloguj się



Statystyki
Użytkowników : 41
Artykułów : 32
Zasoby : 4
Odsłon : 287331
Odwiedza nas
Naszą witrynę przegląda teraz 2 gości 
Google

SP1 do Windows 7 - nowe problemy

Wydawać by się mogło, że ostatnie porady z kulejącym service packiem do MS Windows 7 rozwiążą problem na zawsze. Nic bardziej mylnego, ponieważ zawsze może pojawić się kolejny "zonk": błąd numer 0x80070490 czyli ERROR_NOT_FOUND.

Czegóż to nie potrafi odnaleźć instalator naszego ulubionego SP1? Pierwszym pomysłem jest Google, bo jakżeby inaczej?
Wyników sporo - widać problem powszechnie znany i zbadany, dość szczegółowo opisany na przykład na tej stronie, ale... Czy na pewno wszystko zadziała...?

W moim pierwszym przypadku - zadziałało. W drugim poszło totalnie źle. W każdym można odpuścić sobie zaglądanie do pliku C:\Windows\Logs\CBS\CBS.log (zakładam,że macie "okna" w standardowej lokalizacji), w celu skrupulatnego wypisania, a następnie odinstalowania wszystkich poprawek (KBxxxxxx), przy których w CBS.log widniał komunikat o błędzie, bo te błędy wynikają z innych przyczyn, ale to już odrębna historia. Z zawartości pliku możemy dowiedzieć się jedynie, że najczęściej problem tkwi w sterownikach. Odrzućcie również proponowane przez Microsoftu korzystanie z płyty instalacyjnej i sztuczną "aktualizację" systemu z pobraniem najnowszych aktualizacji z sieci.
Kolejny trop jest już najczęściej trafiony, ponieważ rozwiązanie znajduje się w pliku C:\Windows\Inf\setup.dev.log. I tylko w nim.
Odszukajcie wszystkie wiersze, które zawierają linie podobne do poniższych:

!!!  sto: Failed to find driver update
'C:\Windows\WinSxS\x86_nvraid.inf_31bf3856ad364e35_6.1.7600.16778_none_39bef1ad20475e88\nvraid.inf' in Driver Store. Error = 0x00000490
<<<  Section end 2011/12/30 14:22:27.997
<<<  [Exit status: FAILURE(0x00000490)]

i macie winowajcę na widelcu: tu jest nim NVRAID.INF.
Co dalej? Korzystamy z narzędzia pnputil.exe i korzystając ze ścieżki odnalezionej w setup.dev.log przywracamy sterownik, którego nie mógł namierzyć i zaktualizować Service Pack:

 


W pewnym momencie Windows zaniepokoi się naszym działaniem i wyświetli monit

ale jesteśmy przecież twardzi i pozwolimy na instalację ;-) W ten sam sposób uzupełniamy wszystkie braki i, tak jak w pierwszym moim przypadku, SP1 zainstaluje się bezboleśnie. A jeśli nie...?
Mój drugi przypadek wygenerował taki sam błąd (0x80070490), ale... setup.dev.log nie zawierał żadnych komunikatów o problemach. Ba, plik modernizowany był ponad rok temu! Jednym słowem: plik dziennika nie był zapisywany. Dlaczego?
Odpowiedź po żmudnych poszukiwaniach znalazłem tu, a idąc tym tropem tu. To nic, że w tytule jest Vista - byłem w domu :-)
Od razu trzeba uruchomić edytor rejestru (regedit.exe) i przejść do gałęzi:
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Setup
Tam, w kluczu LogLevel należy ustawić wartość REG_DWORD na domyślną czyli 0 (szesnastkowo 0x00000000), zamknąć edytor i zrestartować system. Od tej chwili wszelkie niepowodzenia instalatora SP1 numerze 0x80070490 będą skrzętnie zapisywane w dzienniku setup.dev.log.
Korzystając z polecenia pnputil.exe uzupełniajcie wszelkie braki, aż nastąpi moment, że przy restarcie systemu po instalacji SP1 Windows nie zamknie się na 9-11%, a na 30 i dokończy dzieło przy ponownym uruchomieniu.
Powodzenia!

Komentarze (0)
Tylko zarejestrowani użytkownicy mogą pisać komentarze!

Zmieniony (Niedziela, 23 Wrzesień 2012 12:51)

 

Rapidox.pl

Wsparcie finansowe

Wsparcie na rozwój
polonizacji jetAudio

Reklama
Helion.pl